Log In

Log In



Not registered yet?


Reset password Activation link

Forums ~ Noticed some issue with QuintaDB?

HTTP/HTTPS issue

November 16, 2012
Completed
0
 

whiteheatreg
November 16, 2012

Can you help with this please. I have a acquired a new computer that I am keeping as virgin so that I can test applications. One issue that I have with my Record View html content is that IE8 and 9 display the Mixed Content message – which the only solution I know is to change the browser security settings. However, I note that on the QuintaDB web site your own examples do not have this message displayed in your demo databases.

I can see that my using my own html content I have replaced what could be the calls to prevent this, here is a paste from one your demo sites;
<br /> <!DOCTYPE html><br /> <html><br /> <head><script type="text/javascript">var NREUMQ=NREUMQ||[];NREUMQ.push(["mark","firstbyte",new Date().getTime()]);</script><br /> <title>Templates - Yellow Paper</title><br /> <meta name='robots' content='nofollow' /><br /> <meta name='norton-safeweb-site-verification' content='5nfikchek440qhex6rp4dkx9npmeh28xacb9rvrrepzszlqdkwyw-pt9y2ihu305uvqebpgyvc74zxc4yhlop2t0izzl67sl9469gy9nfm18qukwywqtobu5qd3b5hix' /><br /> <meta name='verify-v1' content='EoGNPmzsb8tOdi3BLwyMOJWLuZ+ukwVWNq6vQ7hxgzY=' /><br /> <meta name='wot-verification' content='37363603f1e6ae4be0db' /><br /> <link href='/blog.rss' rel='alternate' title='RSS' type='application/rss+xml' /><br /> <meta http-equiv='Content-Language' content='English' /><br /> <meta http-equiv='Content-Type' content='text/html; charset=utf-8'/><br /> <script type='text/javascript'><br /> __RULES = []<br /> </script><br /> <script src='/javascripts/all_app.js' type='text/javascript'></script><!--[if lte IE 7]><br /> <link href='http://MyTaskHelper.com/stylesheets/ie.css' media='screen' rel='stylesheet' type='text/css' /><br /> <![endif]--><br /><br />


Should I be using a similar head content in my html? If so, what are the defaults?

The links are called within a Record View html directly from QuintaDB url fields. The only exception is a Mail to link calling an QuintaDB email link. There are no other links than within the QuintaDB database record. Here is a test page url;

http://www.markwardproperty.com/for_sale_ELITE_DEMO.htm


It seems that if QuintaDB calls Record View then the fact that it uses https and other links in the database are normal http that IE (fine in Firefox and Google Chrome) wants the user to respond to a badly phrased security message. For the time being I will insert a help link on the pages to explain the issue but we really should have a better work around that this. Is it possible for QuintaDB to either detect the existence of http calls and then use http to access Record View? Or is there some way that Record View be parameter set by the developer/user to use http?

I know and understand this is not an issue of your making, however if users are to feature url links in their database and call these from Record View then QuintaDB should be able to facilitate this without having web site visitors be potentially frightened away from applications by a Microsoft message.

Igor Petrushenko
November 18, 2012

Hi Reg!

Most probably this is because your site uses HTTP, but you integrating widget using HTTPS, i.e.:
<iframe src='https://MyTaskHelper.com/apps/dcP8kmv8niWPFdGx8dWRbL/widgets/aGW6nKbCnpWPJdImkpBqTy?view=bfhbuhvmjgg6lcU8kAwXDB'<br />

I can recommend you replacing HTTPS with HTTP and see what happen. So it should be:

<iframe src='http://MyTaskHelper.com/apps/dcP8kmv8niWPFdGx8dWRbL/widgets/aGW6nKbCnpWPJdImkpBqTy?view=bfhbuhvmjgg6lcU8kAwXDB'<br />

Share the discussion in the social networks: